import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\+\\] Software in use: (.+?)(?:( - v(\\d+.\\d+))|$)";
final String string = "[+] Software in use: Calculator\n\n"
+ "or, in some cases, the software version number is shown:\n\n"
+ "[+] Software in use: Calculator - v2.3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}