const regex = /\[\+\] Software in use: (.+?)(?:( - v(\d+.\d+))|$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\+\\] Software in use: (.+?)(?:( - v(\\d+.\\d+))|$)', 'gim')
const str = `[+] Software in use: Calculator
or, in some cases, the software version number is shown:
[+] Software in use: Calculator - v2.3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}