import re
regex = re.compile(r"\[\+\] Software in use: (.+?)(?:( - v(\d+.\d+))|$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("[+] Software in use: Calculator\n\n"
"or, in some cases, the software version number is shown:\n\n"
"[+] Software in use: Calculator - v2.3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")