#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\[\+\] Software in use: (.+?)( - v(\d+.\d+))?\b"
Local $sString = "[+] Software in use: Calculator" & @CRLF & _
"" & @CRLF & _
"or, in some cases, the software version number is shown:" & @CRLF & _
"" & @CRLF & _
"[+] Software in use: Calculator - v2.3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")