re = /\[\+\] Software in use: (.+?)( - v(\d+.\d+))?\b/im
str = '[+] Software in use: Calculator
or, in some cases, the software version number is shown:
[+] Software in use: Calculator - v2.3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end