$re = '/\[\+\] Software in use: (.+?)( - v(\d+.\d+))?\b/im';
$str = '[+] Software in use: Calculator
or, in some cases, the software version number is shown:
[+] Software in use: Calculator - v2.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);