using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\+\] Software in use: (.+?)( - v(\d+.\d+))?\b";
string input = @"[+] Software in use: Calculator
or, in some cases, the software version number is shown:
[+] Software in use: Calculator - v2.3";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}