#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?=.{58}2\)\?\.\*\\.{186}\\2\\\(\)\{2\}\.\*\/$)((.*)(\2\2)?.*\/\2\^\2\(\2\?=\2\.\2\{58\2\}2\2\\\2\)\2\\\2\?\2\\\2\.\2\\\2\*\2\\\2\\\2\.\2\{186\2\}\2\\\2\\2\2\\\2\\\2\\\2\(\2\\\2\)\2\\\2\{2\2\\\2\}\2\\\2\.\2\\\2\*\2\\\2\/\2\$\2\)\2\(\2\(\2\.\2\*\2\)\2\(){2}.*"
Local $sString = "/^(?=.{58}2\)\?\.\*\\.{186}\\2\\\(\)\{2\}\.\*\/$)((.*)(XXX2)?.*\/^(?=.{58}2\)\?\.\*\\.{186}\\2\\\(\)\{2\}\.\*\/$)((.*)(XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX\2\(){2}.*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")