$re = '/^(?=.{58}2\)\?\.\*\\\\.{186}\\\\2\\\\\(\)\{2\}\.\*\/$)((.*)(\2\2)?.*\/\2\^\2\(\2\?=\2\.\2\{58\2\}2\2\\\\\2\)\2\\\\\2\?\2\\\\\2\.\2\\\\\2\*\2\\\\\2\\\\\2\.\2\{186\2\}\2\\\\\2\\\\2\2\\\\\2\\\\\2\\\\\2\(\2\\\\\2\)\2\\\\\2\{2\2\\\\\2\}\2\\\\\2\.\2\\\\\2\*\2\\\\\2\/\2\$\2\)\2\(\2\(\2\.\2\*\2\)\2\(){2}.*/';
$str = '/^(?=.{58}2\\)\\?\\.\\*\\\\.{186}\\\\2\\\\\\(\\)\\{2\\}\\.\\*\\/$)((.*)(XXX2)?.*\\/^(?=.{58}2\\)\\?\\.\\*\\\\.{186}\\\\2\\\\\\(\\)\\{2\\}\\.\\*\\/$)((.*)(XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX\\2\\(){2}.*/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);