import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{58}2\\)\\?\\.\\*\\\\.{186}\\\\2\\\\\\(\\)\\{2\\}\\.\\*\\/$)((.*)(\\2\\2)?.*\\/\\2\\^\\2\\(\\2\\?=\\2\\.\\2\\{58\\2\\}2\\2\\\\\\2\\)\\2\\\\\\2\\?\\2\\\\\\2\\.\\2\\\\\\2\\*\\2\\\\\\2\\\\\\2\\.\\2\\{186\\2\\}\\2\\\\\\2\\\\2\\2\\\\\\2\\\\\\2\\\\\\2\\(\\2\\\\\\2\\)\\2\\\\\\2\\{2\\2\\\\\\2\\}\\2\\\\\\2\\.\\2\\\\\\2\\*\\2\\\\\\2\\/\\2\\$\\2\\)\\2\\(\\2\\(\\2\\.\\2\\*\\2\\)\\2\\(){2}.*";
final String string = "/^(?=.{58}2\\)\\?\\.\\*\\\\.{186}\\\\2\\\\\\(\\)\\{2\\}\\.\\*\\/$)((.*)(XXX2)?.*\\/^(?=.{58}2\\)\\?\\.\\*\\\\.{186}\\\\2\\\\\\(\\)\\{2\\}\\.\\*\\/$)((.*)(XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX\\2\\(){2}.*/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}