re = /^(?=.{58}2\)\?\.\*\\.{186}\\2\\\(\)\{2\}\.\*\/$)((.*)(\2\2)?.*\/\2\^\2\(\2\?=\2\.\2\{58\2\}2\2\\\2\)\2\\\2\?\2\\\2\.\2\\\2\*\2\\\2\\\2\.\2\{186\2\}\2\\\2\\2\2\\\2\\\2\\\2\(\2\\\2\)\2\\\2\{2\2\\\2\}\2\\\2\.\2\\\2\*\2\\\2\/\2\$\2\)\2\(\2\(\2\.\2\*\2\)\2\(){2}.*/
str = '/^(?=.{58}2\\)\\?\\.\\*\\\\.{186}\\\\2\\\\\\(\\)\\{2\\}\\.\\*\\/$)((.*)(XXX2)?.*\\/^(?=.{58}2\\)\\?\\.\\*\\\\.{186}\\\\2\\\\\\(\\)\\{2\\}\\.\\*\\/$)((.*)(XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX\\2\\(){2}.*/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end