using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[w][w][w].[^\-][a-zA-Z0-9-]{3,63}\.co.uk$)";
string input = @"www.byronsargeant.co.uk";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}