package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^[w][w][w].[^\-][a-zA-Z0-9-]{3,63}\.co.uk$)`)
var str = `www.byronsargeant.co.uk`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}