re = /(^[w][w][w].[^\-][a-zA-Z0-9-]{3,63}\.co.uk$)/
str = 'www.byronsargeant.co.uk'
# Print the match result
str.match(re) do |match|
puts match.to_s
end