$re = '/(^[w][w][w].[^\-][a-zA-Z0-9-]{3,63}\.co.uk$)/';
$str = 'www.byronsargeant.co.uk';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);