using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<id>\d+) \| (?<events_raw>[^\|]+) \|";
string input = @"1234 | [[`Event1`,1435],[`Event2`,78],[`Event3`,142]] |";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}