$re = '/(?<id>\d+) \| (?<events_raw>[^\|]+) \|/mi';
$str = '1234 | [[`Event1`,1435],[`Event2`,78],[`Event3`,142]] |';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);