const regex = /(?<id>\d+) \| (?<events_raw>[^\|]+) \|/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<id>\\d+) \\| (?<events_raw>[^\\|]+) \\|', 'gmi')
const str = `1234 | [[\`Event1\`,1435],[\`Event2\`,78],[\`Event3\`,142]] |`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}