package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?<id>\d+) \| (?<events_raw>[^\|]+) \|`)
var str = `1234 | [[\`Event1\`,1435],[\`Event2\`,78],[\`Event3\`,142]] |`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}