package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\+971|00971|0)(?:2|3|4|6|7|9|50|51|52|55|56)[0-9]{7}$`)
var str = `00971551234567
+971551234567
+97141234567
0551234567
041234567
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}