const regex = /^(?:\+971|00971|0)(?:2|3|4|6|7|9|50|51|52|55|56)[0-9]{7}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+971|00971|0)(?:2|3|4|6|7|9|50|51|52|55|56)[0-9]{7}$', 'gm')
const str = `00971551234567
+971551234567
+97141234567
0551234567
041234567
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}