re = /^(?:\+971|00971|0)(?:2|3|4|6|7|9|50|51|52|55|56)[0-9]{7}$/m
str = '00971551234567
+971551234567
+97141234567
0551234567
041234567
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end