import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+971|00971|0)(?:2|3|4|6|7|9|50|51|52|55|56)[0-9]{7}$";
final String string = "00971551234567\n"
+ "+971551234567\n"
+ "+97141234567\n"
+ "0551234567\n"
+ "041234567\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}