#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)foo((?!foo).)*pattern[^\]]*\]"
Local $sString = "foo" & @CRLF & _
"foo" & @CRLF & _
"..." & @CRLF & _
"bar" & @CRLF & _
"..." & @CRLF & _
"pern" & @CRLF & _
"..." & @CRLF & _
"]" & @CRLF & _
"]" & @CRLF & _
"foo" & @CRLF & _
"pattern" & @CRLF & _
"]" & @CRLF & _
"]" & @CRLF & _
"foo" & @CRLF & _
"]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")