import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "foo((?!foo).)*pattern[^\\]]*\\]";
final String string = "foo\n"
+ "foo\n"
+ "...\n"
+ "bar\n"
+ "...\n"
+ "pern\n"
+ "...\n"
+ "]\n"
+ "]\n"
+ "foo\n"
+ "pattern\n"
+ "]\n"
+ "]\n"
+ "foo\n"
+ "]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}