using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo((?!foo).)*pattern[^\]]*\]";
string input = @"foo
foo
...
bar
...
pern
...
]
]
foo
pattern
]
]
foo
]
";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}