re = /foo((?!foo).)*pattern[^\]]*\]/
str = 'foo
foo
...
bar
...
pern
...
]
]
foo
pattern
]
]
foo
]
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end