package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(?:[0-9]+\s*,\s*){1,100}$`)
var str = `02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1012312313123131232102241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}