// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^(?:[0-9]+\s*,\s*){1,100}$").unwrap();
let string = "02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1012312313123131232102241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,
02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}