import re
regex = re.compile(r"^(?:[0-9]+\s*,\s*){1,100}$", flags=re.IGNORECASE)
test_str = ("02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,\n"
"02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,\n"
"02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1012312313123131232102241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,\n"
"02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,\n"
"02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")