import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9]+\\s*,\\s*){1,100}$";
final String string = "02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,\n"
+ "02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,\n"
+ "02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1012312313123131232102241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,\n"
+ "02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,\n"
+ "02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,1000012945631,1000018112,1000021645,1000031573,1000031602,1000031610,1000031645,1000031653,02241026,03800063860001,\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}