$re = '/([Ss][Ll][Nn])\s+(\d+)\s+[Gg][Rr][Pp]\s+\d+\s+[S][T][Y][P]\s+\S*\s/m';
$str = 'SLN 4 GRP 662 STYP \'TZ\' SNO 1037 DRX -3.41018E-15 2.25685E-15 -1 XFLG \'PLA\' ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);