import Foundation
let pattern = #"([Ss][Ll][Nn])\s+(\d+)\s+[Gg][Rr][Pp]\s+\d+\s+[S][T][Y][P]\s+\S*\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"SLN 4 GRP 662 STYP 'TZ' SNO 1037 DRX -3.41018E-15 2.25685E-15 -1 XFLG 'PLA' "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)