import re
regex = re.compile(r"([Ss][Ll][Nn])\s+(\d+)\s+[Gg][Rr][Pp]\s+\d+\s+[S][T][Y][P]\s+\S*\s", flags=re.MULTILINE)
test_str = "SLN 4 GRP 662 STYP 'TZ' SNO 1037 DRX -3.41018E-15 2.25685E-15 -1 XFLG 'PLA' "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")