# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([ADFJMNOS]{1,3}\w*\s) ([0-9]{1,2},\s) ([0-9]{4})/\1\2\3/gmix;t' <<< "April 15, 2015 coordinating committee"