import re
regex = re.compile(r"""
([ADFJMNOS]{1,3}\w*\s) ([0-9]{1,2},\s) ([0-9]{4})
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = "April 15, 2015 coordinating committee"
subst = "\\1\\2\\3"
result = regex.sub(subst, test_str)
if result:
print(result)