// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)([ADFJMNOS]{1,3}\w*\s) ([0-9]{1,2},\s) ([0-9]{4})").unwrap();
let string = "April 15, 2015 coordinating committee";
let substitution = "\\1\\2\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}