package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mix)([ADFJMNOS]{1,3}\w*\s) ([0-9]{1,2},\s) ([0-9]{4})`)
var str = `April 15, 2015 coordinating committee`
var substitution = "\1\2\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}