#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-2]\d:[0-5][0-9]\-[0-2]\d:[0-5][0-9])"
Local $sString = "- von 08:00-12:00uhr und 12:00-22:00 uhr" & @CRLF & _
"- von 08:00-12:00 uhr " & @CRLF & _
"- von 08:00-12:00 uhr" & @CRLF & _
"- von 08:00-12:00" & @CRLF & _
"- 08:00-12:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")