use strict;
my $str = '- von 08:00-12:00uhr und 12:00-22:00 uhr
- von 08:00-12:00 uhr
- von 08:00-12:00 uhr
- von 08:00-12:00
- 08:00-12:00';
my $regex = qr/([0-2]\d:[0-5][0-9]\-[0-2]\d:[0-5][0-9])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}