re = /([0-2]\d:[0-5][0-9]\-[0-2]\d:[0-5][0-9])/
str = '- von 08:00-12:00uhr und 12:00-22:00 uhr
- von 08:00-12:00 uhr
- von 08:00-12:00 uhr
- von 08:00-12:00
- 08:00-12:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end