# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-2]\d:[0-5][0-9]\-[0-2]\d:[0-5][0-9])"
test_str = ("- von 08:00-12:00uhr und 12:00-22:00 uhr\n"
"- von 08:00-12:00 uhr \n"
"- von 08:00-12:00 uhr\n"
"- von 08:00-12:00\n"
"- 08:00-12:00")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.