#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!deal_string)[a-m].*$"
Local $sString = "assets/filename.ext -> pass" & @CRLF & _
"deal_string/filename.ext -> fail" & @CRLF & _
"deal_string.ext -> fail" & @CRLF & _
"deal_string_1.ext -> fail" & @CRLF & _
"deal_draft.txt -> pass" & @CRLF & _
"assets_deal_string.txt -> pass" & @CRLF & _
"bombay.txt -> pass" & @CRLF & _
"zombie.srt -> fail" & @CRLF & _
"some_deal_string.txt -> fail" & @CRLF & _
"zobie_special_string.txt -> fail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")