import re
regex = re.compile(r"^(?!deal_string)[a-m].*$", flags=re.MULTILINE)
test_str = ("assets/filename.ext -> pass\n"
"deal_string/filename.ext -> fail\n"
"deal_string.ext -> fail\n"
"deal_string_1.ext -> fail\n"
"deal_draft.txt -> pass\n"
"assets_deal_string.txt -> pass\n"
"bombay.txt -> pass\n"
"zombie.srt -> fail\n"
"some_deal_string.txt -> fail\n"
"zobie_special_string.txt -> fail")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")