$re = '/^(?!deal_string)[a-m].*$/m';
$str = 'assets/filename.ext -> pass
deal_string/filename.ext -> fail
deal_string.ext -> fail
deal_string_1.ext -> fail
deal_draft.txt -> pass
assets_deal_string.txt -> pass
bombay.txt -> pass
zombie.srt -> fail
some_deal_string.txt -> fail
zobie_special_string.txt -> fail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);