import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!deal_string)[a-m].*$";
final String string = "assets/filename.ext -> pass\n"
+ "deal_string/filename.ext -> fail\n"
+ "deal_string.ext -> fail\n"
+ "deal_string_1.ext -> fail\n"
+ "deal_draft.txt -> pass\n"
+ "assets_deal_string.txt -> pass\n"
+ "bombay.txt -> pass\n"
+ "zombie.srt -> fail\n"
+ "some_deal_string.txt -> fail\n"
+ "zobie_special_string.txt -> fail";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}