import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<!\\d\\. )([A-Z\\s]+)";
final String string = "HEADER ONE: Some text within header one.\n\n"
+ "HEADER TWO: Some text within header two. More lines of text within header two.\n\n"
+ "1. SUBHEADER INSIDE HEADER TWO: Some text within subheader two.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}