const regex = new RegExp('^(?<!\\d\\. )([A-Z\\s]+)', 'gm')
const str = `HEADER ONE: Some text within header one.
HEADER TWO: Some text within header two. More lines of text within header two.
1. SUBHEADER INSIDE HEADER TWO: Some text within subheader two.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}