use strict;
my $str = 'HEADER ONE: Some text within header one.
HEADER TWO: Some text within header two. More lines of text within header two.
1. SUBHEADER INSIDE HEADER TWO: Some text within subheader two.';
my $regex = qr/^(?<!\d\. )([A-Z\s]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}