re = /^(?<!\d\. )([A-Z\s]+)/m
str = 'HEADER ONE: Some text within header one.
HEADER TWO: Some text within header two. More lines of text within header two.
1. SUBHEADER INSIDE HEADER TWO: Some text within subheader two.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end